PDA

View Full Version : Attention all scenery creators, a possible bug in your scenery


jonwil
09-18-2005, 07:23 AM
There is an issue with the scenery importer that could affect your scenery.

It is not present in version 10 but is present in version 9.

It may cause issues with the scenery under some circumstances because it doesnt match with what is expected by the game.

The fix is to re-export the scenery in question using the latest importer version (really anything >= 10 will do) but the latest is best.

To tell if any of your scenery is affected, open the .common.ovl file for the scenery (not the style.common.ovl) in a hex editor (or if you dont have one of those, something like notepad might work)
If you see the string SceneryItem followed by svd (with some numbers inbetween them) you have a bad scenery item and it needs to be re-exported.
If you see the string SceneryItemVisual followed by svd, then you have a working item and no action needs to be taken.

If you think some of the scenery in the pack was exported by one version and some by another version, it might be a good idea to check all the scenery objects in the pack :)

You do not need to change the .thm file or the style.common.ovl or the .ase files at all. (if the affected scenery was built with version 6 or below, you probobly need to deal with the new UI for making scenery that was added to support multiple mesh objects etc.
You may need to flip the texture 180 so that its "up the right way" when looked at in the paint program (older versions of the importer had an issue where the texture had to be flipped to make it work right, newer versions dont have that).

Needless to say, dont use any version below 10 to build scenery anymore otherwise you will be affected by this bug. (using the latest is the best though)

If you are good with a hex editor, it might be possible to fix it by changing the string SceneryItem to SceneryItemVisual and the 0B 00 just before the string to 11 00 (must be done in both .common.ovl and .unique.ovl for each affected item) but I wouldnt recommend it unless you are good with a hex editor (and needless to say, make backups in case you stuff anything up)

If you need the latest scenery importer version, download from http://users.tpgi.com.au/adsloptd/rct3imp12.zip

Just to help people out, here is a list of which scenery from my own collection has this issue: (I may not have the latest version of all of these though)
Comic Heroes set
Feen Letters Arial
Feen Letters Wall
Hollywood Sign
KLN Electro Set
KLN Framework
MNM Dark Ride
PNP Food & Drink
PNP Wall Set
Pumper Dark Ride Set
Pumper Steel Worx
Pumper Blox
Ride Backdrops (Viper etc)
Tidus Wall Set
Top Gun
Warner Bros Logo

The fix will not affect the use in parks or require any changes to parks using the scenery.
All it will do is to correct an issue that could cause the game to refuse to recognize the scenery properly in some cases.

Needless to say, people using scenery that is broken should update to fixed scenery when it is available.

iceatcs
09-18-2005, 10:57 AM
i have re-update all everytime you gave me new version of importer. and those are working well with the latest version. (even in BETA too)

Caffinated
09-18-2005, 11:07 AM
So, you should be able to open the theme in V.11.1 and just re"install" to fix it? Or would I have to go through every single one of the scenery items and redo all the options there? (Original packs made in 6.1)

jonwil
09-18-2005, 11:29 AM
You have to re-save all the scenery.

Also, Ice, I can confirm that the curve slide supports and the brand name logos dont have the bug.
But, the IceatcsHollywoodSignV2 does have it.

marnetmar
09-18-2005, 11:50 AM
Thanks for the info Jonwil :up: :up:

PooSay
09-18-2005, 12:05 PM
So that's why it always crashes when I use SteelWrox and save it :rolleyes:. I don't know what you mean to do to fix it so does anyone wanna reupload the fixed SteelWorx? :)
I'm still confused. Can we fix the problem ourselves or do the scenery creators have to fix them? I dl'd that program that you posted the link to but I don't understand. :noob:

Edited to merger the double post, please refrain from using a scond post wjhen an edit can be done.

iceatcs
09-18-2005, 04:56 PM
You can't fix it, Only the creators can.

Yeah my hollywood sign was used by v6.1 but i have reinstalled for v11.2 on my system but i am holding it for Wild! then i can release it

JCat
09-18-2005, 07:17 PM
Steelworx was created with 6.1 , not 9 - there have been no other reported problems similar to this so I'm not sure what the problem is there. Steelworx will be reissued after Wild is released.

iceatcs
09-18-2005, 07:39 PM
well Steelworx (and many other custom sceneries) is quite unstable when you play the RCT3 too long, as which some of supports are missing on the scenery list. but you can take it back by re-load park again... maybe it is bug for old jowil's importer problem.

anyway can't wait you reissue it when wild out, cos it is best custom sceneries so far.

jonwil
09-18-2005, 08:28 PM
Why wait untill Wild! comes out?

So you can check compatibility?

JCat
09-18-2005, 09:11 PM
Exactly, plus I'm beta testing, so right now, I can't fiddle around with scenery anyway. It's best to have a new set that will work with Wild as I don't want to reininstall now, and then have to redo it again when Wild comes out if there are changes that need to be made (particularly beacuse of the size of the package).

marnetmar
09-18-2005, 09:24 PM
Originally posted by iceatcs
well Steelworx (and many other custom sceneries) is quite unstable when you play the RCT3 too long

That's news to me, I haven't seen or heard any of these problems mentioned by anyone here.

iceatcs
09-18-2005, 10:32 PM
Well i normally using RCT3 on my laptop, so i sometime left the park with full of customs on for 6 hours as my habit. As well my stuffs but when reimport latest one and it seems fine for while.

marnetmar
09-18-2005, 10:41 PM
Originally posted by iceatcs
Well i normally using RCT3 on my laptop, so i sometime left the park with full of customs on for 6 hours as my habit. As well my stuffs but when reimport latest one and it seems fine for while.

Sounds like it's a problem caused by leaving the game running for 6 hours that's causing things to disappear rather than the theme's themselves.

iceatcs
09-18-2005, 11:14 PM
Well it is only happening on custom, so I am surely it is deffo something up on custom.
I didnít care to report it early because it is easy to get it back by re-load the park and it is only it will be missing on the list not that it disappear itself in the park.

It happened to me about 50% of every time when I forget about leaving RCT3 on my laptop.

JCat
09-18-2005, 11:46 PM
I have the same problem with my lap top when I leave it on for many hours unattended...... even without scenery. :)

Park Novice
11-01-2005, 04:49 PM
I'm just back from an extend period of time away from the forums and, this is not the best of news. For all those people using my packs, I will endevour to have updated releases week commencing 21st November.

Sawyer
11-01-2005, 04:53 PM
I hope this can get fixed = (

All of your should deserves to be shown of in wild = (

Klinn
11-01-2005, 04:58 PM
Park Novice, to get back up to speed, you may want to read about the custom scenery issues in Wild (http://www.ataricommunity.com/forums/showthread.php?s=&threadid=500028) , and about the new Importer Ver13 (http://www.ataricommunity.com/forums/showthread.php?s=&threadid=500476) . Essentially, you'll just have to re-create the OVLs, update the icon texture to a PNG if you were using a BMP, and repackage the set. Not too difficult, just tedious. ;)

Park Novice
11-01-2005, 05:11 PM
Thanks Klinn, Just downloaded it. Thank god I backed up all the sets otherwise it would have been more tedious than it currently will be.

I'm sure this is Atari screwing with the coding so they can make money from Scenery pack Addons but then again, I'm cynical at the best of time.

jonwil
11-01-2005, 06:24 PM
This is not Ataris fault, its a conbination of a (otherwise harmless) code change in Wild! and a bug in the old versions of my importer.

It does not look like a deliberate attempt to stop custom scenery (the fact that stuff exported with newer versions of the importer works is proof of that)

marnetmar
11-01-2005, 06:31 PM
I remember awhile back I believe it was M Brookes that said there was no attempt by Atari/Frontier to stop the custom scenery from working in the game.