PDA

View Full Version : Models showing up too dark??


Groovdafied
10-27-2005, 12:13 AM
I'm using SIOpaque and a pretty bright texture...
http://dreemaze.com/parks/starfleet/Shot0030.JPG

My regular models are pretty bright, what can I do to solve this?

Der Freak 00
10-27-2005, 09:08 AM
I'm not sure...maybe there's a possibility to solve that problem by using EffectPoints....do you use an Alpha texturere?

Groovdafied
10-27-2005, 04:33 PM
Originally posted by Der Freak 00
I'm not sure...maybe there's a possibility to solve that problem by using EffectPoints....do you use an Alpha texturere?

No I don't use either... Is there a key to the EffectPoints so I know how to use them, and also what will alpha textures do for me and how do I use it?

marnetmar
10-27-2005, 04:38 PM
I'm not sure what modeling program you're using Groovdafied, but try changing the diffuse, specular & ambient settings & then re-import the model into the game to see how it looks. This should lighten the texture up, but you'll probably have to play around with it to see what looks best.

Groovdafied
10-27-2005, 06:44 PM
Originally posted by marnetmar
I'm not sure what modeling program you're using Groovdafied, but try changing the diffuse, specular & ambient settings & then re-import the model into the game to see how it looks. This should lighten the texture up, but you'll probably have to play around with it to see what looks best.

I'm using TrueSpace to model my stuff... I was wondering if anybody used a perticular texture in the mesh flags.

marnetmar
10-27-2005, 07:49 PM
I've never used TrueSpace, but the most common texture setting is the SIOpaque for most any regular textures. I would think there's some way to adjust the diffuse, ambient, etc. settings in the modeling program. That would enable you to lighten up the model itself & therefore lighten the textures when applied.

jonwil
10-27-2005, 08:05 PM
Actually, the settings (like diffuse, ambient and other material settings etc) that you apply in the 3D program are not read by the scenery importer.

Groovdafied
10-27-2005, 08:13 PM
Originally posted by jonwil
Actually, the settings (like diffuse, ambient and other material settings etc) that you apply in the 3D program are not read by the scenery importer.

Any recomendations? Anybody?

shyguy
10-30-2005, 07:29 PM
I've had problems where the light source doesn't shine on the correct surfaces in RCT3.

In other words, I have placed a wall I made next to one that came with RCT3 and the back of my wall is lit up instead of the front of the wall. This makes white textures look dark grey on the front, as if it's in the shadows. By rotatating it in the 3D software and re-importing it, I can get the correct surfaces to light up the same as the existing RCT3 walls.

Not sure if this is your problem, but it might be worth checking out to see if it helps.

DasMatze
03-12-2006, 06:00 PM
I have the same problem like Groovedafied. Im using Anim8or and i set up the diffuse, specular and ambient settings. But nothing happend:
http://www.rctd.ft6.com/uploads/Problem2.JPG
(yes i know, that the object isnt on the right position)

Its on both sides!

I hope anybody can help me.
http://img117.exs.cx/img117/5279/m2vhelp.gif

Greets DasMatze

Edit: Sorry for bumping this Thread.

Guybrush_47
03-12-2006, 06:48 PM
I'm trying to remember why it does go dark. I know there is a reason. I seem to remember you have to set the pivot point correctly. If you do that, the texture should be lighter. As atm theres no light effecting the object, so the engine can't see it to reflect the light off. Probably due to a missaligned pivot point.

marnetmar
03-12-2006, 06:56 PM
I don't know anything about using Anim8or, but I had the same problem a long time ago using Milkshape & what I found to fix it was to make each "side" of the model/wall a seperate piece. In Milkshape you can select by verticies & then choose to "unweld" them. I don't know if Anim8or has this option or not.

Guybrush_47
03-12-2006, 07:02 PM
That shouldn't effect the shadow effect tho Mart. Unwelding the verts is used to take away the smooth mesh. I think it's a pivot problem.

marnetmar
03-12-2006, 07:25 PM
That shouldn't effect the shadow effect tho Mart. Unwelding the verts is used to take away the smooth mesh. I think it's a pivot problem.

I don't use Anim8or, but that solved the issue when using MS.

Guybrush_47
03-12-2006, 07:39 PM
With 3ds, the models had ugly shadows, but light was effecting it when the verts were welded. Seems strange that two pieces of software have different solutions... 'scratches head'.

Either way, i just did a test, and for 3ds, having a bad pivot produces non light reflective surfaces. (i.e. 'dull' textures).

JaySL
03-12-2006, 07:52 PM
It's cool you brought this topic up because that's one of the things I noticed when importing some of the objects I've done before and I thought it was because I wasn't sure if I was doing the right thing... I'll do some research about it and if I find something I'll post it here...

Potter
03-12-2006, 08:26 PM
Actually, I have observed that this problem appears in both the cases that marnetmar and guybrush explained...though both seem unrelated, they have a common issue- improper generation of surface normals (which RCT3 uses to show shadows)

In softwares that support pivot points(like 3ds), a misaligned pivot point causes the model vertexes to be stored with an offset (which affects the generation of normals), which causes them to appear dark ingame.

In other softwares (like MS), the issue is usually with smoothing groups, which affects the generation of normals (http://www.kaon.com/kb/article.php?id=011) . If the whole object belongs to one smoothing group, then this issue is observed. But, if each side is mapped to a different smoothing group or if each side is made a separate piece, this issue can be solved...

CoasterSim.Fan
03-12-2006, 10:21 PM
If some one can come up with a solution using Anim8or pleas let us know because this is something that has annoyed me quit a few times will making textures for models.

marnetmar
03-12-2006, 10:31 PM
Thanks for the info Potter :up: :up:

If some one can come up with a solution using Anim8or pleas let us know because this is something that has annoyed me quit a few times will making textures for models.


CoasterSim.Fan, If there's an option in Anim8or, try selecting by verticie & select all, then choose to unweld, or whatever they might call it & then save & try reimporting & see if that helps.

CoasterSim.Fan
03-12-2006, 10:35 PM
Could it be called detaching all faces? Also if you detach the faces should you be able to move etch one separately.

Guybrush_47
03-13-2006, 03:47 AM
If you detach all the faces, you should be able to then attach them back. As the vertices SHOULD be unwelded. Thats what i do with 3ds, i'm not sure if it will work for you guys tho.

Potter
03-13-2006, 12:56 PM
I got this information from a friend...

"As for the smoothing, unfortunately Anim8or does not support smoothing groups (customization of the smooth angles for defined groups of edges/vertices). Therefore, to get it to look semi-correct in Anim8or, you have to do a bit of playing around with the smooth angle (double click your mesh). Sharper creases will look smoother the higher the angle value."

Hope it helps :)

marnetmar
03-13-2006, 04:46 PM
Could it be called detaching all faces? Also if you detach the faces should you be able to move etch one separately.

That sounds like what you need CoasterSim.Fan, no need to move them though. Once the model/texture mapping is complete, detach the faces & then save/import into the game & see how it looks.

Phil
03-13-2006, 05:10 PM
Ummm did anybody realise DazMatze revived this thread form last year >.>

Guybrush_47
03-13-2006, 06:54 PM
Nope lol

marnetmar
03-13-2006, 07:42 PM
Ummm did anybody realise DazMatze revived this thread form last year >.>

Yes, but it's ok

StayingDead
03-14-2006, 09:36 AM
I suppose it's in the exchange so it doesn't have the 30 day rule. But this problem still exists. Wonder if anyones sorted it yet,