View Full Version : Phantom meshes

11-28-2005, 09:07 AM
After getting a "missing data" error frequently (and the importer crashing and losing all the information everytime) i tried remaking every model about 10 times. Some worked, some didn't.

I noticed the importer crashes when you forget to put texture data with each mesh in the ovl creator. Well thats ok. better it didn't crash though, but even after checking each carefully, it still happened.

Then by chance i clicked accidently below the last mesh and noticed the box highlighted even though the mesh had no name (was blank/inivisble), as if there was a mesh there, even though there was no text. Clicking "don't import mesh" for this solved all the errors. Anyone else noticed this, or know where this ghost mesh is appearing from?

its not the root mesh, that appears as normal in the list.

11-28-2005, 10:38 AM
Missing data mean you haven't put all setting yet, You must put everything, yes everything all the boxes must be fill.

Most common I made mistake is forget to select which theme group, like General, Spooky etc....

Ghost meshes, meaning no textures because it could be a bad format texture file. Or the all the polygon faces are backface which it is invisible, (swap the facing in 3D editor)

11-28-2005, 10:56 AM
I thought maybe they could be 2d splines i forgot to delete in the editor, but its weird how they don't have any name (anim8or automatically gives each mesh a name like "mesh01"). Additionally, i didn't think it would export splines as .3ds but i'm not sure.

i delted all the bad meshes so i don't have a screenshot i don't think, but if it happens again i'll post it.

Or the all the polygon faces are backface which it is invisible, (swap the facing in 3D editor)

This is probably the most likely reason, but dosn't explain why they are nameless in the importer.

Although easily disabled in the menu, it took me ages to realise they were there in the first place because they are invisible!

EDIT: heres a screen of the invisible mesh shows what i mean better....


Mesh flags can be edited as normal, but i didn't know it was there.

Der Freak 00
11-28-2005, 11:57 AM
I have the same problem, but only when I use objects with many meshes. If I have 1 or 2 meshes it don't happen.

Don't know why they're invisible:(

11-28-2005, 12:07 PM
You might want to open up your ASE file in Notepad and see what's in there. Each object should be defined within a set of curly brackets like this:


In the ASE's output from Max, the first entry within an object gives it's name, like this:

*NODE_NAME "Cylinder05"

So perhaps you've got geometry object group near the bottom of your ASE that doesn't have the name entry? Just throwing out guesses. ;)

11-28-2005, 12:11 PM
as der freak said, you got to many meshes, I have the same problem if I try to import to many meshes as 1 object

11-28-2005, 01:02 PM
i see, well yeah look at notepad on ASE file to see how many objects apart from root. counting by like klinn said.

if it is part of your model, you might need to naming it like


put any name, maybe better use 'mesh05' which it isn't your list.

if it is mesh is nothing to do, then tick the 'don't import mesh'

11-28-2005, 01:20 PM
it apparently, although i'm not 100% sure, dosn't do anything, so i don't import it.

I never read anything about this until now.